Back to overview
Degraded
MPC Network Degraded
Nov 24 at 03:43am CET
Affected services
MPC - Testnet
Resolved
Nov 24 at 11:28am CET
The issue has been resolved, almost MPC nodes (+9 nodes) are now reachable again.
The MPC network status has been switched back to Optimal on the status page
Affected services
Created
Nov 24 at 03:43am CET
The MPC decentralized network is currently in a degraded state on the status page.
We are detecting 8 reachable parties, which is below the expected threshold for normal operation.
We are actively investigating connectivity issues and will keep you updated as the situation evolves.
Affected services