Back to overview
Degraded

MPC - Testnet is down

Feb 12, 2026 at 10:39am UTC
Affected services
MPC - Testnet

Resolved
Feb 12, 2026 at 6:02pm UTC

MPC - Testnet recovered.

Created
Feb 12, 2026 at 10:39am UTC

MPC - Testnet is degraded.