Mainnet MPC Downtime
Resolved
Mar 24, 2026 at 12:03pm UTC
The MPC service is now fully operational again. The previous issue has been completely resolved, and all functions are back online.
Affected services
Updated
Mar 24, 2026 at 10:32am UTC
We have partially resolved the issue on the MPC mainnet. Thank you for your patience.
Affected services
Created
Mar 24, 2026 at 9:02am UTC
We are currently investigating a critical incident affecting the mainnet MPC service.
Following a restart of the KMS connector (listener) this morning, the service was no longer able to correctly filter blockchain events and started returning the following error: -32000: filter not found.
As a result of this issue, the mainnet MPC service is currently down.
Our team is actively investigating and working to restore the service as quickly as possible. We will share further updates as soon as we have more information.
Affected services