Back to overview
Degraded

MPC - Testnet and MPC - Mainnet are down

Apr 18, 2026 at 4:16pm UTC
Affected services
MPC - Testnet
MPC - Mainnet

Resolved
Apr 20, 2026 at 4:53pm UTC

MPC - Testnet recovered.

Updated
Apr 20, 2026 at 4:43pm UTC

MPC - Testnet is degraded.

Updated
Apr 20, 2026 at 3:29pm UTC

MPC - Testnet recovered.

Updated
Apr 20, 2026 at 3:14pm UTC

MPC - Testnet is degraded.

Updated
Apr 20, 2026 at 2:53pm UTC

MPC - Testnet recovered.

Updated
Apr 20, 2026 at 12:58pm UTC

MPC - Testnet is degraded.

Updated
Apr 20, 2026 at 12:47pm UTC

MPC - Mainnet recovered.

Updated
Apr 20, 2026 at 12:37pm UTC

MPC - Mainnet is degraded.

Updated
Apr 20, 2026 at 12:22pm UTC

MPC - Testnet recovered.

Updated
Apr 20, 2026 at 11:02am UTC

MPC - Testnet is degraded.

Updated
Apr 20, 2026 at 5:33am UTC

MPC - Testnet recovered.

Updated
Apr 20, 2026 at 3:48am UTC

MPC - Testnet is degraded.

Updated
Apr 20, 2026 at 2:29am UTC

MPC - Testnet recovered.

Updated
Apr 20, 2026 at 1:09am UTC

MPC - Testnet is degraded.

Updated
Apr 20, 2026 at 12:29am UTC

MPC - Testnet recovered.

Updated
Apr 19, 2026 at 11:04pm UTC

MPC - Testnet is degraded.

Updated
Apr 19, 2026 at 10:36pm UTC

MPC - Testnet recovered.

Updated
Apr 19, 2026 at 9:16pm UTC

MPC - Testnet is degraded.

Updated
Apr 19, 2026 at 4:32pm UTC

MPC - Testnet recovered.

Updated
Apr 19, 2026 at 3:02pm UTC

MPC - Testnet is degraded.

Updated
Apr 19, 2026 at 6:22am UTC

MPC - Mainnet recovered.

Updated
Apr 19, 2026 at 4:49am UTC

MPC - Testnet recovered.

Updated
Apr 19, 2026 at 2:32am UTC

MPC - Mainnet is degraded.

Updated
Apr 19, 2026 at 2:04am UTC

MPC - Testnet is degraded.

Updated
Apr 19, 2026 at 12:31am UTC

MPC - Testnet recovered.

Updated
Apr 18, 2026 at 9:41pm UTC

MPC - Testnet is degraded.

Updated
Apr 18, 2026 at 9:23pm UTC

MPC - Testnet recovered.

Updated
Apr 18, 2026 at 8:03pm UTC

MPC - Testnet is degraded.

Updated
Apr 18, 2026 at 5:36pm UTC

MPC - Testnet recovered.

Created
Apr 18, 2026 at 4:16pm UTC

MPC - Testnet is degraded.